Home / Wordpress Problem & Issues / How To Solve LayerSlider Old jQuery Issue
layerslider old jquery issue

How To Solve LayerSlider Old jQuery Issue

While working on one of my elegant clients blog I face this issue. He was using a older version of WordPress and I updated it to 3.6.1 and just after the update, what I saw, a “LayerSlider: old jQuery issue”. Its one of the strangest issue I face. Because I just update the WP version and all got finished, The site stopped working.

The error message showing LayerSlider old jQuery issue is a common issue which can be arise if you are using Layer Slider and if you have changed your jQuery Version in your website or blog.
Layer Slider is generally used with WordPress Themes. And if you will upgrade or degrade your WordPress version, you can face this problem. Most of the people face this problem while updating there wordpress version to 3.6 or 3.6.1. 3.6.1 is the current version of WordPress and its necessary in terms of security that you should always use updated versions of WP core, wordpress themes and plugins. If you will use older or outdated versions, you are just leaving security loopholes for hackers hackers. WordPress is an open source CMS and used jQuery for its own purpose and also used for functioning with either front end or back-end of blog or site.

This is the a common message showed on website It looks like you are using an old version (1.10.2) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer. If you are using the WordPress version of LayerSlider, you can try out the “jQuery Updater” plugin from the WP plugin depository. If you don’t know what to do, you can write us a private message from our CodeCanyon profile page. We need a temporary WP admin account (or a temporary FTP account in some cases) to solve this issue.

It is totally rediculous what this message show or you can call it a “bug” in programming language. It said you are using an old version (1.10.2) and Layer Slider requires at least version 1.7.0 . But in real scenario 1.7.0 is a lower version and 1.10.2 is a higher version. Which I think is a mistake and this message makes no sense.

But the total conclusion is that your website does not used the supporting version of jQuery.

The real cause of this issue is Layer Slider itself. Because WordPress 3.6.1 uses 1.10.2 version of jQuery and Layer Slider is asking to update it. Which is not possible as its already on its latest version. The issue arise when Layer slider check for jQuery version on WordPress. And it can be solved by editing jQuery files in Slider Plugin.

If you are facing the same issue here is the solution for wordpress CMS.

Follow these instructions step by step

  • 1. Download the file and Unzip the it, there will be a .js file (download here)
  • 2. Now look for LayerSlider plugin, it can be under /wp-content/plugins/ or
    the /wp-content/themes/ {your-theme-name} / folder, its depend upon your configuration
    or theme you have used (because some theme are loaded with this slider)
  • 3. Upload the recently downloaded and unzipped .js file into your sliders location
    /LayerSlider/js/ folder via FTP or cpanel which ever access you have.
    (It will ask for overwrite the file, you can overwrite it, but keep the older file
    as backup, as I love to keep backup of everything, if you donlt want to keep
    the backup just overwrite it).
  • 4. Its done and Enjoy.

Follow the steps carefully and your old jQuery issue for WordPress will be solved. Happy WordPressing




Want to learn more about Wordpress Issues? Sign up for our newsletter

While working on one of my elegant clients blog I face this issue. He was using a older version of WordPress and I updated it to 3.6.1 and just after the update, what I saw, a “LayerSlider: old jQuery issue”. Its one of the strangest issue I face. Because I just update the WP version …

Review Overview

Solvd LayerSlider Old jQuery Issue
Solvd LayerSlider Old jQuery Issue
Solvd LayerSlider Old jQuery Issue
Solvd LayerSlider Old jQuery Issue

Solvd LayerSlider Old jQuery Issue

User Rating: 4.69 ( 8 votes)
93

About Vandy

Hello Internet World. I am a Wordpress Developer and always Love to dive in WordPess with themes, plugins and custom coding.

25 comments

  1. Hi Onedna
    Can you please help me to remove this error, it has stopped my site.
    My site was running for 4 years and my site was get hacked. One of my friend who is a little bit techy, restored it, and told me to update the version of WP core. I update my wordpress version as he suggested and now its not working, Only showing the Error “layerslider old jquery issue” .

    I have sent a message. Please check and reply as soon as possible.

    Grit M

  2. Thanks for the help! It is very useful and i solve my problem right now!
    You make my day. :)

  3. LOVE YOU! Really…thank you man!

  4. excelente muchas gracias, me sirvio esta ayuda

  5. It helps me to get back my site, thanks for helpful article and you have explained everything in details,

  6. It works to me. Thank you very much.

  7. thanks for help…it’s really work :D

  8. Thank you for the advice. Sadly, it didn’t work for me. The plugin lived in a slightly different folder if that makes any difference, in [themename[/framework/plugins/LayerSlider/js but that’s definitely the only LayerSlider folder on my page. I tried deactivating a jquery update (in regular plugins) as a troubleshooting step but to no avail.
    The original issue was that certain elements quickly flashed from the slider, and this .js file didn’t solve that and added an issue when the slider transitions from one slide to another (it goes out of it’s boarders).
    Obviously I’ve reverted back to the old file and am very grateful for even this help. Anything you might suggest? Thanks

    • Hi
      As you said it seems that the slider is integrated with your theme and running from there. I’ll suggest you to ask the theme seller they will also help you.
      Have a good day.

  9. Looks like I am a little late to this party :-)

    The slider disappeared for me too. I uploaded the new js file and still nothing :-(

    All plugins were disabled to see if it was a conflict. Still nothing. I can see the preview, just cannot see it on the site.

    I cleared the cache and all cookies.

    Any thoughts?

    Thanks.

  10. Did all the instructions, it worked. thank you

  11. Thanks! This solved my problem!

  12. Elianderson Costa

    Thank you! My problem is Solved!

  13. 1000 x thank you!

  14. Thank you very much for this solution. I thought it looked kind of like a stupid error message, and I wasted plenty of time looking for the problem until you showed me the right answer. Thank you very much.

  15. Thanks, this worked great.

  16. Thank you !!!!!!

Leave a Reply

Your email address will not be published. Required fields are marked *

*